Présentation de 7×8

Présentation de « 7×8 »

Ce logiciel a pour but de faciliter l'apprentissage et la consolidation des tables de multiplication.

Il peut être utilisé à la maison, ou à l'école.

En mode école, différentes fonctionnalités permettent le suivi d'une ou de plusieurs classes, avec bilans ponctuels, graphiques de progression, et statistiques

« 7x8 » est un FREEWARE , c'est-à-dire qu'il est complètement gratuit.

Il peut être copié et diffusé à volonté, à la seule condition qu'il reste gratuit .

Il est distribué tel quel, avec ses qualités et ses défauts, sans aucune garantie d'aucune sorte, qu'elle soit expresse ou implicite.


Installation de 7×8

Installation

Dans notre collège, ce logiciel a tourné jusqu'en 2006 sur de vieux 486 sous Windows 95.
Autant dire qu'il peut être installé sur n'importe quel PC pas trop vétuste.
Il peut être utilisé sous Linux (via Wine), mais il semble qu'il y ait de petits problèmes d'affichage.
Sinon, il fonctionne correctement sous toutes les versions de windows jusqu'à xp. Des problèmes ont été signalés sous vista. A confirmer.

À la maison :

L'installation est « propre » : elle n' ajoute ni clé dans la base de registre, ni dll ou autre. Tous les fichiers copiés sont dans le même répertoire.

Pour désinstaller, on peut, au choix, effacer le répertoire « 7x8 », ou utiliser le programme de désinstallation.

Dans un établissement scolaire :

Pour éviter les nombreux inconvénients de l'utilisation en monoposte, le réseau est quasiment indispensable.

Il faut pour cela installer le logiciel sur chaque poste, en commençant par le serveur, le serveur étant le poste qui hébergera les fichiers des élèves.

Au premier lancement, le logiciel vous demande le chemin de ce serveur. Si vous êtes sur ce serveur, il vous demandera aussi la répartition des classes de votre établissement. Puis, les objectifs de chaque niveau.

Ne pas oublier de cliquer sur "enregistrer" à chaque fois.

Ceci étant fait, il faut que le dossier « 7x8 » du serveur soit partagé en accès complet : lecture et écriture.

En principe, sur les autres postes, l'installation est plus simple: au premier lancement, le logiciel demande le nom du serveur , puis il télécharge automatiquement le fichier de configuration qu'il y trouve.

Ainsi, les élèves peuvent changer de poste d'une séance à l'autre, sans inconvénient.


Tour d'horizon

Au lancement, le logiciel demande l'identité de l'élève, puis il charge le fichier de suivi de cet élève, s'il existe, et un graphique apparaît, représentant la progression. Les barres de ce graphique sont actives : un clic gauche fait apparaître le détail du test et un clic droit sur le dernier test permet de l'imprimer.

Le logiciel propose alors un test portant sur les tables étudiées. A la suite de ce test, s'enchaîne un entraînement pour remédier aux lacunes détectées.

Si l'enchaînement proposé ne vous plaît pas, il est possible d'accéder directement aux différentes activités, grâce aux boutons situés sur la gauche, ou par le menu, section « Apprentissage ».

Le but à atteindre est d'obtenir un score de 100%. En général, la progression s'étale sur plusieurs semaines, en effectuant des séances espacées d'un ou deux jours.

Par défaut, le logiciel traite les tables de 2 à 9. Mais il est possible pour l'élève de ne travailler que certaines de ces tables, grâce aux boutons situés sur la droite.

On peut aussi aller plus loin, en travaillant les tables "étendues": carrés de 11² à 19², et tables de 12 à 19.


Description détaillée

flèche Dans la section « Apprentissage », différentes activités sont proposées :

« Entraînement » par défaut, l'élève apprend une seule table, celle qu'il connaît le moins. On peut modifier ce choix en utilisant la barre d'outils située en haut de l'écran:

barre outils apprentissage
Le premier bouton, actif par défaut, est un apprentissage par tables complètes, le logiciel choisit prioritairement les plus mal sues.
Le second est un apprentissage par produits individuels; ici encore, le logiciel choisit automatiquement.
Le troisième permet un choix libre des tables travaillées.

« Perfectionnement» tables inversées

niveau 1: multiplication à trou, du type "6=3×?". Pas de temps limité.

niveau 2: il faut trouver les deux facteurs, par ex. "6=?×?". Toujours pas de temps limité.

niveau 3: il faut encore trouver les deux facteurs, mais avec limitation de temps. Ce temps se réduit progressivement, avec l'augmentation du score.

flèche Dans la section « Tables » on peut choisir ce qui va être étudié:

« Tables classiques» de 2×2 à 9×9. Pour les petites classes, on peut ne choisir que certaines de ces tables.

« Tables raisonnées» multiplications ne nécessitant pas un apprentissage par coeur, mais la connaissance d'une règle simple.

niveau 1: multiplications par 0, par 1, et par 10.

niveau 2: multiplications par 11, par 20, et par 50.

« Tables étendues» table des carrés de 11² à 19², puis tables de 12 à 19. Pour les élèves ayant atteint un score de 100%.

flèche Dans la section « Primaire » destinée aux petites classes:

« Additions» les additions à un chiffre

niveau 1: lecture graphique des nombres groupés par 5 ou 10. Utilisable dès 5 ou 6 ans.

niveau 2: additions dont le total est inférieur à 10.

niveau 3: compléments à 10.

niveau 4: additions dont le total est supérieur à 10.

« Entraînement clavier» pour les enfants peu familiarisés avec le pavé numérique qui perdent du temps à chercher les chiffres.

flèche Dans la section « Réglages » on peut choisir le mode "école" ou "maison", ainsi que la valeur de divers paramètres, comme les temps de réponse.


Utilisations en classe

Utilisation en classe

Dans la section « Enseignant », apparaissent différents onglets :

Etablissement: on peut définir entièrement l'établissement scolaire et ses divisions. Par défaut, la configuration est celle du collège de Tocane-Saint-Apre, ce qui donne un exemple facile à modifier.

Paramètres Cette section contient les mêmes options que celles de Réglages décrites dans le « tour d'horizon », plus les suivantes :

« dossier élèves en réseau » le dossier dans lequel tous les fichiers des élèves sont stockés, dès que ce dossier est détecté.

« dossier élèves monoposte » le dossier dans lequel le fichier de l'élève est stocké, tant que le dossier élèves en réseau n'est pas détecté.

« dossier statistiques » le dossier dans lequel les bilans et statistiques sont enregistrés par défaut.

« code professeur » si nécessaire, possibilité d'un code de 4 lettres . Si ce champ est vide, l'accès à la section Enseignant est libre.

Bilans individuels : c'est dans cet onglet que l'on visualise les résultats de tous les élèves.

Le bouton « créer liste élèves » engendre une liste de tous les élèves, rangés par classe. Le score affiché est celui du premier test effectué. Pour les classes, il s'agit de la moyenne. Si l'on clique sur un nom, le détail des tests de l'élève est affiché à droite. On peut imprimer, ou même enregistrer au format pdf . Si c'est une classe qui est sélectionnée, le fichier pdf contiendra les tests de tous les élèves de la classe (pratique, pour copier sur une disquette, imprimer…).

Notez que l'arborescence du volet gauche peut étre imprimée. De plus, elle s'enregistre automatiquement dans le répertoire « stats» sous la forme d'un fichier texte nommé « liste_eleves.txt ».

Le bouton « historique complet » est pour l'instant inactif.

Statistiques produits cette section permet de comparer le taux de méconnaissance des différents produits. Et ceci, dans une classe entière, ou toutes les classes d'un niveau, ou tout l'établissement. Une fois les classes choisies, le bouton « lancer calcul » fait apparaître une nouvelle page (ci-dessous). Dans cette page, une grille montre le pourcentage de réponses fausses ou absentes pour chaque produit:

En prime, on a la liste de toutes les confusions, classées par ordre de fréquence. Cette liste est récupérable par un copier-coller.

Statistiques élèves cette section semble maintenant être à peu près stable, du moins pour les options actives. Il y a pour l'instant huit types de statistiques possibles :

comparaison des classes ou des niveaux d'un établissement. Grâce à cet outil, il a été constaté que les élèves de troisième savent toujours mieux leurs tables que les élèves de sixième. La progression est lente en 6ème-5ème, puis s'accélère en 4ème-3ème. Et ceci, sans aucune action spécifique de la part des enseignants.

histogramme de répartition des différents résultats : ce graphique montre, par exemple, combien d'élèves ont un score compris entre 90 et 100%, combien entre 80 et 90%, etc. Beaucoup plus instructif que la simple moyenne.

Dans les options encore inactives, parce qu'encore expérimentales, on pourra comparer les résultats de différents groupes d'élèves, selon tout critère, à toutes fins utiles, de recherche ou autre. Par exemple, il a été constaté que les filles et les garçons ont des résultats moyens rigoureusement identiques (alors que, par ailleurs, les filles sont meilleures en orthographe).

Edition champs élèves dans cette section, on crée ou modifie des bases de données de renseignements concernant les élèves. Ces bases de données seront ensuite utilisées dans la section précédente, pour les statistiques par critère supplémentaire (celles qui sont encore inactives).


En projet

Améliorations futures

7×8 est en pleine évolution: la version téléchargeable sur le site est changée plusieurs fois par an.

En projet:

Optimisation de la méthode d'apprentissage.

Sonorisation.

Traduction dans d'autres langues.

Exercices variés : calcul mental, opérations posées, décomposition de nombres, nombres premiers, puis fractions, racines carrées..

L'achèvement de la partie "statistiques", encore incomplète.

Un vrai tableau de bord de l'élève, avec diagnostic, progression et conseils.

Un meilleur suivi des classes.

Rendre l'interface plus conviviale et intuitive.

Lorsque ce stade sera atteint, le numéro de version passera à "1.0"


Sous le capot

Qu'y a-t-il sous le capot ?

Ce logiciel est programmé en Delphi, et ce depuis 1997.

Une première tentative en Visual Basic, deux ans plus tôt, n'avait guère été convaicante.

Sur internet, on peut trouver des milliers de composants et codes sources variés pour Delphi, mis gratuitement à la disposition de tous par leurs auteurs du monde entier.

par exemple, 7x8 utilise les composants suivants :

TshapeEx, de Mat Ballard (Australie)

TDanHint, de Peter Plass (Allemagne)

TGradLabel, de Mik Tran (Australie)

TNPDF, de K.Nishita (Japon)

TRotateLabel, de Joerg Lingner (Allemagne)

TTiledBitmap, de Daniel Parnell (Australie)

TRichView, de Sergey Tkachenko (Russie)

Simons Komponenten, de Simon Reinhardt (Allemagne)